# 介绍

Nuxt 的 TypeScript 支持有三个依赖套件 :

@nuxt/types

Version Downloads

包含 Nuxt 的 TypeScript 类型定义。

它们按照Nuxt内核代码维护见代码 nuxt/nuxt.js

@nuxt/typescript-build

Version Downloads

能让 Nuxt 在 layouts, components, pluginsmiddlewares 中使用 TypeScript。

@nuxt/typescript-runtime

Version Downloads

Nuxt 封装了二进制文档来为 nuxt.config 配置文件, 本地 modulesserverMiddlewares 提供对于 TypeScript runtime 的支持。

WARNING

这些依赖套件只支持 Nuxt 2.10 or 更高版本.